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Copyright  2004 by NHRC LLC 

This document contains proprietary information that  is the confidential property 
of NHRC LLC. 

No part of this document may be used or reproduced, by any means, or for any 
purpose, without the express written consent of NHRC LLC. 

No part of this document should be considered to be specifications for the proper 
or correct operation of the NHRC-10 Programmer.  In no way will NHRC LLC be 
liable for direct or indirect damages to the controller or attached equipment. 

 

 

Warranty 
 

This software is supplied at no charge with absolutely no warranty.  It may or 
may not be suitable for the purposes described in this manual.  In no case will 
NHRC LLC be liable for any direct, consequential, or incidental loss or damage 
resulting from the use or inability to use this software. 
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Welcome! 
 

Thanks for buying our products.   
 
We have made this programming software available to you free of charge, with 
no support whatsoever.  If you should experience difficulty or discover a problem, 
we’d love to hear about it, but we are under no commitment to fix the problem for 
you. 
 
Please review this manual carefully before putting this software into operation. 
 
This software is delivered as-is at no charge.  Support for the software is not 
available.  It works on our computers.  However, we are interested in your 
feedback about the software.  Email your questions and comments to software-
support@nhrc.net.  Telephone support requests will be refused. 
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1. Introduction 

The NHRC-10 Programming software allows you to easily manage all the 
programming data in your NHRC-10 Repeater Controller.  It allows you to read 
all the configuration data from your NHRC-10 repeater controller to your PC, 
edit the data, save the data to disk, and write the changed data back to your 
controller.  It will support as many different controller configurations as you have 
disk space for, and you can edit your controller data without the controller 
connected. 

The computer communicates with the controller through a serial interface into 
the controller’s CI-V port. 

1.1 Supported Computer Platforms 

The NHRC-10 Programming Software is developed to run on Windows 2000 or 
Windows XP.  It may work in prior versions of Windows, but is not supported on 
any platforms other than Windows 2000 and Windows XP. 

The software requires about 150 Kbytes of disk space.  Each saved repeater 
configuration requires 8 Kbytes.   

In order to communicate with NHRC-10 controllers, the computer must have a 
RS-232 port on COM1: available.  A CI-V interface is required to connect to the 
controller. 

1.2 Supported Repeater Controller Software 

The NHRC-10 Programming Software is written to be compatible with NHRC-
10 software version 1.20.  New features in future NHRC-10 software versions 
may not be supported by this software. 

1.3 Controller Interface 

The NHRC-10 programming software communicates with the target NHRC-10 
controller through the computers serial port into the controllers CI-V port.  The 
RS-232 port on your computer cannot be directly connected to a CI-V device.  A 
CI-V interface box is required. 

An Icom CI-V interface can be used, a CI-V interface circuit from the internet, or 
a Yaesu ADMS cable can be used with an adapter. 

You must provide your own CI-V interface. 
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2. Using the NHRC-10 Programming Software 

This section of the manual describes how to use the NHRC-10 Programming 
Software. 

2.1 Installation 

The NHRC-10 Programming Software is distributed by electronic download or 
on 1.44 MB floppy.  The installer consists of a Microsoft Setup package called 
“Setup NHRC-10 Programmer.msi”.   

To install the NHRC-10 programming software, locate the msi file with the 
Windows Explorer program by clicking on “My Computer” and then navigating 
to the diskette or folder where the “Setup NHRC-10 Programmer.msi” is.  
Double-click on the “Setup NHRC-10 Programmer.msi” file to start the 
installation. 
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When the installation starts, click the “Next” button to start the installation 
process.  The installer will them prompt you for the location to install the NHRC-
10 Programmer and which users should have the NHRC-10 startup icon added to 
their start menus. 

 

It is quite reasonable to accept the defaults and simply click “Next” on this 
dialog. 
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The installer will then install the software.  A few more clicks of “Next” and the 
installation successful message will be shown.  Click “Close” to finish the 
installer. 

 

 

2.2 Starting the NHRC-10 Programmer 

To start the NHRC-10 Programming Software, press the Windows “Start” button.  
Select “Programs” and navigate to the menu called “NHRC”, clicking on the 
“NHRC-10 Programmer” selection.  This will start the program.  The main 
window will be displayed 

 

The main window displays a simple guide to using the program.  The following 
sections will describe the three main tasks in using the NHRC-10 Programmer. 
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2.3 Basic Operation 

The NHRC-10 Programmer application is used to edit NHRC-10 Repeater 
Controller configurations.  All the configuration data in the controller’s 
EEPROM can be edited with this program.  Audio tracks are not stored in the 
configuration EEPROM and cannot be edited with this program. 

In order to edit the controller data, the program must first load the data from 
either a controller, or a controller configuration data file stored on the computer. 

Once the data is loaded, the program can be used to edit it. 

Finally, when the configuration data has been edited, it should be saved to 
computer disk and/or into a NHRC-10 repeater controller. 

2.3.1 Loading Data 

Controller data can be loaded from disk files stored on the computer, or loaded 
from a NHRC-10 repeater controller. 

2.3.1.1 Reading controller configuration files from disk 

To read controller data files from disk, use the “File” menu “open” selection.  A 
Windows file dialog box will appear, and you will be able to navigate to and 
select the controller data file you want to edit.   
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The NHRC-10 Programmer includes a sample data file.  This data file is installed 
to the same location the application files were, normally  

C:\Program Files\NHRC\NHRC LLC\NHRC-10 Programmer\nhrc10.bin 

This configuration file contains the default (as initialized) data from a NHRC-10 
repeater controller, and is the same as starting off by reading a freshly initialized 
controller. 

When a file is selected and successfully read by the NHRC-10 Programmer, the 
filename will appear in the title bar. 

Reading controller configuration data from a controller. 

Connect the CI-V interface to your computer’s COM1 serial port and the 
controller’s CI-V port. 

Select the “File” menu “Read From Controller” option.  

The controller data will begin to transfer, and the “Transferring Data” message 
will appear. 

 

The configuration data takes between two and three minutes to transfer. 

If the CI-V interface is not correctly connected, one or more error messages will 
appear and the data will not be successfully transferred. 

 

Controller is not powered up. 
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Controller not connected. 

 

Controller lost power during transfer 

2.3.2 Editing Data 

Once valid configuration data has been loaded into the NHRC-10 Programming 
Software, the next step is to edit the data.  The “Edit” menu provides access to all 
the editing functions of the software, including  

• Timer Presets 

• Command Prefixes 

• Autopatch Setup including restrictions 

• Autodial Setup 

• Emergency Autodial Setup 

• Access to all Control Operator settings for all saved states 

• Courtesy Tones 

• CW ID message 

The functions on the Edit menu are described in detail in Section 3 of this 
manual. 

2.3.3 Saving Data 

Controller data, once edited, should be saved to a disk file and/or to a NHRC-10 
repeater controller. 



NHRC-10 Programmer User Guide 

2.3.3.1 Saving Configuration Data to Disk 

To save controller configuration data to disk, select either the “File” menu 
“Save” or “Save As…” option.  The “Save As” choice will cause the “Save As” 
dialog box to appear.  Choose a directory, specify a file name, and click the 
“Save” button to save the controller configuration data 

 

If you select the “Save” option, and you have already specified a file name 
(either by previously loading a file, or by using the “Save As…” function) the 
program will quietly save your data to disk. 

If “Save” is selected, and a file name has not already been specified the “Save 
As” dialog will be shown, and you will have to select a location and filename to 
save the file. 

2.3.3.2 Saving Configuration Data into a Controller 

To load the controller with the edited data, use the “File” menu “Write to 
Controller” option.  The “Transferring Data” window will appear, and the data 
will be transferred to the controller.  It takes about 3 minutes to transfer the data 
to the controller. 
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If the configuration data cannot be successfully transferred, one of the three error 
messages shown in section 2.3.1.1 will be displayed. 

Caution: The transfer of data writes the EEPROM as the data is received.  If the 
transfer does not successfully complete, the controller’s configuration data is in 
an unknown state (at best!), and should be reloaded completely. 

2.4 Displaying Version Information 

The version number and copyright information can be shown by selecting the 
“Help” menu “About” option. 

 

2.5 Uninstalling the NHRC-10 Programming Software 

The NHRC-10 Programming software can be removed from your computer by 
using the “Add or Remove Programs” icon in the Windows control panel.  Select 
“NHRC-10 Programmer from the list of programs in the “Add or Remove 
Programs” window and press the “Remove” button.  Press “Yes” to the “Are you 
sure you want to remove NHRC-10 Programmer from your computer, and the 
program will be uninstalled. 
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3. Editing The NHRC-10 Configuration Data 

All the configuration data used by the NHRC-10 that is stored in EEPROM can 
be edited with the NHRC-10 Programmer.  The voice recorder tracks are not 
stored in the controller’s data EEPROM and cannot be edited by this software.   

The configuration data is all edited by selecting functions on the “Edit” menu. 

The choices on the “Edit” menu include options for “Autodial”, “Autopatch”, 
“Control Operator Switches”, “Courtesy Tones”, “CW ID”, “Emergency 
Autodials”, “Prefixes” and “Timers”. 

Each option will be discussed in the following sections of this manual. 
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3.1 Edit Autodials 

The NHRC-10 Repeater controllers support an autodial directory of up to 250 
phone numbers of 15 digits each.  The NHRC-10 Programmer makes editing 
autodial data a snap!  Use the “Edit” menu “Autodials” option to display the “edit 
Autodials” window 

 

This window allows editing of up to 10 autodial slots at a time.  It consists of a 
“Select Range” dropdown menu and 10 autodial slots.  Use the “Select Range” 
control to choose which 10 are displayed.  Edit the telephone numbers and click 
“OK” to close the window. 
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3.2 Edit Autopatch Configuration 

The NHRC-10 repeater controller has a “restricted autopatch” feature.  The 
restricted autopatch feature allows the repeater controller to enforce a set up rules 
about what telephone numbers can be called. 

The restricted autopatch allows up to 16 different area codes to be programmed.  
Each area code can restrict or require the use of a leading “1” digit, use a dial 
prefix (for long distance access or a “9” outside line digit for PBX operation).  
One area code bank (#15) can be specified as the local area code to allow 7- or 8-
digit dialing.  

In addition to those rules, each of the 800 possible exchanges within an area code 
can be individually restricted. 

Consult the “Program Autopatch Restrictions” of your NHRC-10 Repeater 
Controller manual for more details on how the autopatch restrictions work. 

Use the “Edit” menu “Autopatch” option, and select which of the Area Code 
configurations you want to edit. 
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The “Edit Autopatch Configuration” window will be displayed. 

 

Enter the area code in the area code field. 

If this area code bank is to be enabled, check the box. 

If a leading “1” digit is allowed when calling this area code, check the “Leading 
1 Allowed” box.  This will allow 10- and 11- digit dialing, provided the first digit 
in an 11-digit sequence is a 1. 

If a leading “1” is required when calling this area code, check the “Leading 1 
Required” box.  This will require that the called number is 11 digits long and the 
first digit is a 1. 

IF you are editing the configuration data for area code #15, the “Local Area 
Code” box will be active.  Check this box to allow the settings for area code 15 to 
be use for all 7 and 8 digit telephone numbers. 

To have this area code always dial a certain prefix before dialing, check the “dial 
prefix enabled” box, and enter the prefix in the “Dial Prefix” field.  (example “9” 
or “10288”.) 

The restrictions for the individual exchanges 200 through 999 can be edited using 
the “Enable All”, “Disable All”, and “Edit Each” buttons.  Clicking “Enable All” 
will set all exchanges (from 200-999) to enabled (dialable).  Clicking “Disable 
All” with set the exchanges disabled (undialable).  Clicking the “Edit Each” 
button will display the “Edit Exchanges” window. 
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The Edit Exchanges window allows for any exchange from 200 to 999 to be 
individually edited.  100 exchanges can be seen at once.  Use the “Select Range” 
dropdown menu to select a different range of exchanges to edit.  Click the “ok” 
button when done. 
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3.3 Edit Control Operator Switches 

The NHRC-10 has 80 control operator switches that adjust features on the 
controller.  The controller can save the state of all 80 control operator switches.  
Five saved states are permitted.  Saved state number zero (0) is loaded at 
controller power up. 

The NHRC-10 Programmer software will allow you to edit the values saved in 
each of the saved setups. 

Use the “Edit” menu “Control Operator Switches” option, and select which of the 
saved state configurations you want to edit. 

 

Once you select a set, the Edit Control Operator Settings window will be shown. 

 

Use the drop down menu to select which Control Operator Group you want to 
edit.  The names to the left of the checkboxes will change as you select different 
groups.  Check the boxes to enable features you want.  Consult the NHRC-10 
manual for a description of each control operator switch. 
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3.4 Edit Courtesy Tones 

All eight courtesy tones can be edited with the NHRC-10 Programmer.  Use the 
“Edit” menu “Courtesy Tones” option to display the “Edit Courtesy Tones” 
window. 

 

The dropdown menu at the top of the window selects which of the eight courtesy 
tones is displayed in the window.  Each courtesy tone can be programmed as 
either a sequence of up to 4 audio tones, or as a single CW character. 

3.5 Edit CW ID 

The NHRC-10’s CW ID can be edited with the NHRC-10 Programmer software.  
Use the “Edit” menu “CW ID” option to display the “Edit CW ID” window. 

 

Type the ID message you want to use, then click OK. 
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3.6 Edit Emergency Autodials 

The NHRC-10 supports 10 Emergency Autodial slots in addition to the 250 
Autodial slots.  The phone numbers stored in the 10 Emergency Autodial slots 
can be edited with the NHRC-10 Programmer.  Select the “Edit” menu 
“Emergency Autodials” option to display the Edit Emergency Autodials window. 

 

Edit the telephone numbers for each slot, and click OK. 
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3.7 Edit Prefixes 

All the user commands for the NHRC-10 require a prefix to secure access.  The 
NHRC-10 Programmer can edit the prefixes.  Use the “Edit” menu “Prefixes” 
option to display the Edit Prefixes window. 

 

Enter the prefixes and click OK.  Consult the NHRC-10 manual for more 
information on the command prefixes. 



NHRC-10 Programmer User Guide 

3.8 Edit Timers 

Each of the 14 timers in the NHRC-10 can be programmed with the NHRC-10 
Programming software.  Use the “Edit” menu “Timers” option to display the 
“Edit Timers” window. 

 

Type your timer values and click OK to accept the changes.  Consult the NHRC-
10 manual for information on timer uses and default values. 
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